Back to overview
Downtime

Network interruptions

Apr 23, 2026 at 7:41am UTC
Affected services
Verification (v.secident.com)
Admin console (admin.secident.com)
API (api.secident.com)

Resolved
Apr 23, 2026 at 7:46am UTC

We do not monitor any more issues at the moment.

Created
Apr 23, 2026 at 7:41am UTC

We’re currently experiencing network interruptions and are investigating the problem together with our data center.